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Who am I? 

•  Associate Professor in Computer Science, 
mainly in Software Engineering 

•  Research interests:  
– Multiagent systems 
– Agent oriented software engineering (AOSE) 

•  Modeling (Agent UML among others) 
•  Methodology 

– Model-driven Engineering 
– Big data 
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Where do I work? 

LISTIC laboratory 
–  Image processing 
–  Information fusion and processing 
– Fuzzy functions 
– Ontology 
– Software engineering 
– Performance analysis 
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Annecy 

Photo montagne 

Annecy, little Venice 
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Talk outline 

•  Introduction towards model-driven 
development 

•  What is a model? 
•  Model-Driven Architecture (MDA) 
•  Model-Driven Engineering (MDE) 
•  Domain-Specific Languages (DSL) 
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Model 

Model-driven Architecture 
(MDA) 

Model-driven Engineering 
(MDE) 

Model to Model 
(M2M) 

Model to Text 
(M2T) 

Domain-specific Language 
(DSL) 

Model-driven Development 
(MDD) 
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Model-Driven Development 
 

(or: Why I'd like writing programs that write programs  
rather than writing programs…) (J.-M. Jezequel) 
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Introduction towards  
Model-Driven Development 
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1950s 

•  Computers and programs appear 
•  Programs are no longer military ones 
•  Programs are written with machine code: 

100110011… 
•  Machine code is part of first generation languages 
•  But second generation languages appear such as 

Assembler to reduce complexity to develop 
programs 

•  And some third generation languages such as 
FORTRAN (1954) 
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1960s 

•  The term « Software Engineering » is 
coined at the NATO Conference in 1969 
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1970s 

•  Third generation languages such as C 
(Ritchie, 1972) 
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1980s 

•  From procedural languages to object 
programming, C++ (1983) 
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1990s 

•  Classes are packed into packages and 
components : component-based 
programming 
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2000s 
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Complexity is  
everywhere 

Lines of Code 
– Windows NT 3.1: 5M LOC 
– Windows 2000: >29M LOC 
– Mac OS X 10.4: 89M LOC 
– Firefox: 1M LOC 
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Complexity is 
everywhere (cont’d) 
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Complexity is  
everywhere (cont’d) 
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The death march of 
specifications 

J2EE Date of release 
1.0 1999 
1.1 
1.2 2000 
1.3 2001 
1.4 2003 
5 2006 
6 2010 
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Too many platforms 

•  Technological platforms 
–  .NET 
– Java (SE, EE, ME) 

•  Hardware platforms 
– Xbox 360 
– PS3 
– Wii 

•  Etc. 
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The Military Medical Information 
Systems Example 

•  No common NATO Electronic Health Record 
–  Nations’ own responsibility 

•  “Push” from national EHR to NATO: No semantics or syntax standard 
agreed upon 

–  Periodic reports about medical status 
•  Delayed and aggregated: Not good enough for many purposes 

•  26 NATO member nations 
–  26 different Electronic Health Records (at least: one nation may have 

more than one system) 
–  26 different technological “platforms”? 
–  26 different “standards”? 
–  Maturity of systems varies 

•  Multinational Integrated Medical Unit (MIMU) 
–  Many nations in one medical treatment facility 
–  Should (must?) share information 
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Snapshot CIM 
Models 

PIM 
Models 

PSM (Java) 
Models 

System Java 
Code 

PSM (.Net) 
Models 

System .Net 
Code 

NATO MC326/AJP4.10 
STANAGS and CIV STD 

Standard Mapping 
Rules and Patterns 

26 different  
platforms 
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If you were still not convinced… 

From the Standish group, in 2003, on 13522 
IT projects 

•  34% respect the deadline and cost 
•  51% respect the deadline but increase the 

cost 
•  16% are stopped before ending 
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It is time to change the  
way to develop software 
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Model-Driven Development 
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Philosophy behind  
model-driven development 

•  Gains abstraction: adopt an eagle’s eye 
view of software rather than a mole’s one 

•  Gets separation of concerns between 
business stuff and technological one 

•  Modifies the leitmotive « Write once, runs 
everywhere » to « Model once, generate 
anywhere » 
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What is a model? 
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Why modeling? 

Modeling, in the broadest sense, is the cost-effective 
use of something in place of something else for 
some cognitive purpose. It allows us to use 
something that is simpler, safer or cheaper than 
reality instead of reality for some purpose. 

 
A model represents reality for the given purpose; the 

model is an abstraction of reality in the sense that it 
cannot represent all aspects of reality. This allows us 
to deal with the world in a simplified manner, avoiding 
the complexity, danger and irreversibility of reality. 

 
Jeff Rothenberg 
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One real « car »: several models 
depending on the point of view… 
Hundreds of thousands data… 
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Ferrari F60 

Different points of view for modelling: 
•  If you are Scuderia addict: 

– Drivers 
– Nb of victories 
– Etc. 

•  If you are an engineer: 
– Nb of horsepower 
– Maximum speed 
– Etc. 

Simplified view of system 
and with only worthwhile data 
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What is a model? 

[OMG MDA Guide 1.0.1]  
A model of a system is a description or 

specification of that system and its 
environment for some certain purpose. A 
model is often presented as a combination 
of drawings and text. The text may be in a 
modeling language or in a natural language. 
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Tower 

One model, two instantiations 
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Model 

•  A model is a description, a partial specification of 
a system: 
–  Abstraction of a real entity with only interesting 

features for a given context and a given aim 
–  Subjective view of a system 

•  The aim of a model is: 
–  Ease the understanding of a system 
–  Simulate a system under use 

•  Outstanding examples: 
–  Economical models 
–  Social models 
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Model-Driven Architecture 
(MDA) 
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Model-Driven Architecture 
(MDA) 

•  Proposed by the Object Management Group 
(OMG) consortium 

•  Part of a collection of standards 
– UML 
– SysML 
– XMI 
– MOF 
– SPEM 
– CWM 

•  Uses extensively UML models 
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Model-driven Architecture  
(MDA) 

•  Separation of business functions from 
technological implementation 
– Represent common concepts in a model 

independent of computation and technological 
platforms  

•  CIM: Computation Independent Model 
•  PIM: Platform Independent Model 

– Use the PIM model transformation to create new 
platform specific models 

•  PSM: Platform Specific Model 

– Generate executable code (applications) from the 
PSM 
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Several models 

•  CIM (Computation Independent Model): 
this is the business model, frequently 
realized during requirements engineering 

•  PIM (Platform Independent Model): this is 
the instance of the application 

•  PSM (Platform Specific Model): this is the 
instance of the application for a specific 
platform (either technical or conceptual) 
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The Four Modeling Layers of the OMG 
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Layer M0: instances 

At the M0 layer, there is the running system 
in which the actual (« real ») instances 
exist. 

This is where you do the « new » in object-
oriented programs 

 
But to define these instances, we need a 

form: the M1 layer 
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Layer M1: the Model of the 
System 

The M1 layer contains models, for example, 
a UML model of a software system. In the 
M1 model, for instance, the concept of 
Customer is defined with the properties of 
name, street and city 

The M1 elements define what M0 instances 
look like 

But defining models for instances requires to 
know how to model models… 
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Layer M2: The Model of the 
Model 

Classes, operations, attributes and 
associations defined at the M1 layer need 
to be modeled.  

The M2 layer defines how elements at the 
M1 layer should be defined: what is a 
class, what is an attribute, etc. 
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Layer M3: the Model of M2 

•  M0 defines the data for your application 
•  That are based on classes defined in M1 
•  That are based on elements that explained 

how to write classes/concepts: M2 
•  Finally, we need to explain how to write 

these elements: the M3 layer 
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Layer M3 (cont’d) 

And a M4 layer ? 
And a M5 layer ? 
And so on ? 
 
Hopefully not, M3 is a reflexive layer, it is 

used to describe itself 
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M3 Meta-metamodels 

Two meta-metamodels exist to describe 
metamodels:  

•  OMG’s Meta-Object Facility (MOF) 
•  Eclipse Modeling Framework (ecore) 

(discussed in MDE part) 



Page 47 

Meta-Object Facility 

•  Proposed by OMG as support of Model-
Driven Architecture 

•  Comes into two flavours:  
– Essential MOF (EMOF) 
– Complete MOF (CMOF) 

•  Designers do not have to pay too much 
attention about MOF intricacies: tools 
directly represent classes, attributes and 
operations 
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EMOF Packages 
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Essential MOF 

•  Sufficient to represent simple metamodels 
•  Complex metamodels with reflection 

require CMOF 
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XMI 
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XMI 

•  XML Metadata Interchange (XMI) 
•  Part of OMG specifications 
•  Responsible to save MOF (and Ecore) 

objects as an XML file: the M2, M1 and M0 
layers 

•  Used to exchange models between UML 
tools 
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XMI (cont’d) 

<?xml version="1.0" encoding="ISO-8859-1"?> 
<xmi:XMI xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns="Families"> 
  <Family lastName="March"> 
    <father firstName="Jim"/> 
    <mother firstName="Cindy"/> 
    <sons firstName="Brandon"/> 
    <daughters> 
     <firstName>Brenda</firstName> 
    </daughters> 
  </Family> 
  <Family lastName="Sailor"> 
    <father firstName="Peter"/> 
    <mother firstName="Jackie"/> 
    <sons firstName="David"/> 
    <sons firstName="Dylan"/> 
    <daughters firstName="Kelly"/> 
  </Family> 
  <Book> 
   <title> "Easy ATL" </title> 
  </Book> 
</xmi:XMI> 
 

M0 layer example 
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XMI (cont’d) 
<?xml version="1.0" encoding="ISO-8859-1"?> 
<xmi:XMI xmi:version="2.0" 
    xmlns:xmi="http://www.omg.org/XMI" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
    xmlns:ecore="http://www.eclipse.org/emf/2002/Ecore"> 
  <ecore:EPackage name="Families"> 
    <eClassifiers xsi:type="ecore:EClass" name="Family"> 
      <eStructuralFeatures xsi:type="ecore:EAttribute" name="lastName" ordered="false" 
          unique="false" lowerBound="1" eType="#/1/String"/> 
      <eStructuralFeatures xsi:type="ecore:EReference" name="father" ordered="false" 
          lowerBound="1" eType="#/0/Member" containment="true" eOpposite="#/0/Member/

familyFather"/> 
      <eStructuralFeatures xsi:type="ecore:EReference" name="mother" ordered="false" 
          lowerBound="1" eType="#/0/Member" containment="true" eOpposite="#/0/Member/

familyMother"/> 
      <eStructuralFeatures xsi:type="ecore:EReference" name="sons" ordered="false" 
          upperBound="-1" eType="#/0/Member" containment="true" eOpposite="#/0/Member/familySon"/

> 
      <eStructuralFeatures xsi:type="ecore:EReference" name="daughters" ordered="false" 
          upperBound="-1" eType="#/0/Member" containment="true" eOpposite="#/0/Member/

familyDaughter"/> 
    </eClassifiers> 
</xmi:XMI> 
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XMI (cont’d) 

 <eClassifiers xsi:type="ecore:EClass" name="Member"> 
      <eStructuralFeatures xsi:type="ecore:EAttribute" name="firstName" ordered="false" 
          unique="false" lowerBound="1" eType="#/1/String"/> 
      <eStructuralFeatures xsi:type="ecore:EReference" name="familyFather" 

ordered="false" 
          eType="#/0/Family" eOpposite="#/0/Family/father"/> 
      <eStructuralFeatures xsi:type="ecore:EReference" name="familyMother" 

ordered="false" 
          eType="#/0/Family" eOpposite="#/0/Family/mother"/> 
      <eStructuralFeatures xsi:type="ecore:EReference" name="familySon" 

ordered="false" 
          eType="#/0/Family" eOpposite="#/0/Family/sons"/> 
      <eStructuralFeatures xsi:type="ecore:EReference" name="familyDaughter" 

ordered="false" 
          eType="#/0/Family" eOpposite="#/0/Family/daughters"/> 
    </eClassifiers> 
  </ecore:EPackage> 
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XMI (cont’d) 

•  Hopefully for you, you do not have to read 
XMI... 
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Tools for MDA 

•  UML-based tools: Code generation is 
available and for some of them, it is possible 
to modify the templates 
– Poseidon (Gentleware AG), Omondo, Rational 

Rose (IBM), etc. 
•  Specific MDA tools:  

– Commercial: 
•  Mia Software (Mia Software), MetaEdit+ (Metacase) 

– Open Source: 
•  Acceleo, OpenArchitectureWare (retired), Kermeta 

(even if it is a MDE tool) 
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MDA in practice 
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Acceleo 

Available at: http://www.acceleo.org 

Model-to-Text tool 
(M2T) 
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Installation 

1.  Download All-in-one Eclipse Modeling 
Tools (
http://www.eclipse.org/downloads/
packages/eclipse-modeling-tools-
includes-incubating-components/
galileosr1) 

2.  Unzip the archive to a directory 
3.  Execute Eclipse 
4.  Check in File>New you have Eclipse 

Modeling Framework and UML 2.1 
Diagrams 
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Installation (cont’d) 

1.  Go to Help>Install new software 
2.  Click on Button Add and this new site: 

http://www.acceleo.org/update 
3.  Then select the Acceleo site in the combo 

Work with 
4.  Check the Acceleo proposal below as 

shown on Figure 
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Page 65 After clicking Next button 



Page 66 Accept the license agreements and Finish 
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Eclipse is updating the platform with Acceleo features 



Page 68 Acceleo is now ready for use 
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Acceleo in use 

•  Change perspective to the Acceleo one 
(the second in the list of Acceleo 
perspective) 

•  Development following two steps: 
1.  Create the metamodel as UML class 

diagram 
2.  Create the script 
3.  Generate the target model 
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Metamodel creation 

•  File>New>Acceleo>Generator project 
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Metamodel creation 

•  Name your project, here PhoneDirectory 
•  Then, create your metamodel via UML 2 

plugin 
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Complete the dialog window as follows 
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Rename the file as follows 
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Define the model as follows 
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We need to modify the dependencies so as to consider UML diagrams 
when generating code 
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Create an empty generator 
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This template will be filled further 
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We need to associate the model to the template 
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The interface is bugged and we need to click on src to see the template… 
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If template is correctly selected, a marker appears on classes (and elements 
that will be considered for generation) 
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Modifies the template as follows 
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File generation 

The last stage is generating files, right click 
on generator project>Acceleo>Generate 
files 
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Here we are… 
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Acceleo 

Advantages 
•  Easy to use interface 
•  Models are manipulated 

as UML class diagrams 
•  Scripting ease file 

generation 

Drawbacks 
•  This is not a 100% 

compliant tool: 
–  No distinction between 

models and instances 
–  Inability to change the 

metamodel 
–  No transformation rules 

•  Documentation is difficult 
to find 

But it works and this is all we need… 
When requirements are low… 
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Labs on Acceleo (MDA) 

•  Install Acceleo on your machine 
•  Optional (just to get your feet wet) 

– Do the example given in previous slides 
•  Prepare a metamodel corresponding to a 

University (students, lectures, rooms, 
teaching staff) 

•  Create scripts to generate files 
•  Generate files 
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Model-Driven Engineering 
(MDE) 



Page 93 

Introduction 

•  MDA proves its usefulness when 
generating code directly (this is what we 
saw with Acceleo) 

•  MDA is a reality in UML commercial and 
open source tools: we can define modules 
and generate code for a specific platform 

•  MDA is unfortunately too narrow and 
dedicated to UML 
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Model-Driven Engineering 

•  MDE extends MDA so as not to restrict to 
UML metamodel and MOF meta-
metamodel 

•  MDE keeps the philosophy of MDA but 
enlarges it: 
– No predefined meta-metamodel 
– Metamodel can be defined 
– The four modeling layers of OMG really exist 
– Transformation rules are used 
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Model-driven Engineering 
(cont’d) 

What you will consider in MDE: 
•  MOF or Ecore 
•  Eclipse Modeling Framework 
•  M2M via ATL 
•  M2T via template engine 
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Ecore 

•  Proposed in the context of Eclipse 
Modeling Framework (EMF) 

•  Another meta-metamodel 
•  Strong similarity with MOF except: 

– Simpler 
– No association between classes, associations 

are defined as attributes within classes 



Page 97 

Ecore 
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Ecore 

•  Every concept is prefixed with an ‘E’ 
•  We find the usual notions of UML class 

diagrams: 
– Packages with EPackage 
– Classes with EClass 
– Attributes with EAttribute 
– Operations with EOperation 
– Associations with EReference  
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Ecore 

•  EFactory and EObject are used for the M0 
layer: instances 
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Ecore example 
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MDE Process 

1.  Create the source metamodel via Eclipse 
EMF 

2.  Generate an editor to create the source 
model (instance) 

3.  Create the source model 
4.  Create the target metamodel 
5.  Create the transformation rules 
6.  Apply the transformation rules and get the 

target model (instance) 

We will use this approach in Kermeta 
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The Y development cycle 

Y
Business concepts, 
Entities -> CIM, PIM 

Platform 
metamodel 

PSM 

Code 
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MDE Process in  
several flavors 

•  Pure MDE Process:  
– Source and target metamodels with Ecore or 

MOF 
– Transformation rules with ATL 
– Source and target models as an XMI file 
Only three modeling layers in this case (M3, 

M2, M0) 
 

Tool: Kermeta 
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MDE Process in 
several flavors (cont’d) 

•  Extreme Purity: 
–  Source and target metamodels with Ecore or 

MOF 
–  Source and target models with Ecore or MOF 
–  Source and target instances with XMI 
–  Transformation rules with ATL 
The four modeling layers in this approach 
 

Tool: EMF 
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MDE Process in 
several flavors (cont’d) 

•  Flexible attitude: 
– Source and target metamodels with Ecore or 

MOF 
– Source and target models with Ecore or MOF 
– Source and target instances with XMI 
– Transformation rules with Java 

Tool: Dynamic EMF + Velocity + Java 
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Tools for MDE 

•  Kermeta (http://www.kermeta.org) 
•  OpenArchitectureWare: retired (

http://openarchitectureware.org) 
•  OpenEmbedd (http://openembedd.inria.fr) 
•  TopCased (http://www.topcased.org) 
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OpenArchitectureWare 

•  Tools proposed around OAW are now part 
of Eclipse Modeling tools 

•  Retired, tools are now used in Eclipse 
EMF 
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OpenEmbedd 

•  MDE platform for real-time and embedded 
systems 

•  Based on Eclipse and Eclipse modeling 
tools 

•  Strong industrial tool with academic 
partners specialist in Model-Driven 
Engineering 

The different tools used in OpenEmbedd are the ones in  
Kermeta and EMF 
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TopCased 

•  MDE platform for critical systems 
•  Strong support from industry 
•  Based on Eclipse (Eclipse RCP, Eclipse 

Modeling tools) 
•  Specific tools from partners: model 

checking, analysis, etc. 

The different tools used in OpenEmbedd are the ones in  
Kermeta and EMF 
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MDE in practice 
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Kermeta 

•  MDE platform 
•  Based on Eclipse 
•  Kermeta = Metamodeling + Behavior 
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Installation 

•  Download All-in-one Eclipse Modeling 
Tools (
http://www.eclipse.org/downloads/
packages/eclipse-modeling-tools-includes-
incubating-components/galileosr1) 

•  Unzip the archive to a directory 
•  Execute Eclipse 
•  Check in File>New you have Eclipse 

Modeling Framework and UML 2.1 
Diagrams 
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Installation (cont’d) 

•  Go to Help>Install new software 
•  Click on Button Add and this new site: 

http://www.kermeta.org/update 
•  Then select the Kermeta site in the combo 

Work with 
•  Check the Kermeta proposal below as 

shown on Figure 
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Change the perspective to the Kermeta one 
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Creating the source metamodel 

Two possibilities: 
– From a file using the Kermeta notation (KM3) 
– From an Ecore file 

Or you could be more exotic with annotated 
Java files, UML class diagrams, or 
Rational Rose models 
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Creating from a Kermeta file 
Create an empty project from 

File>New>Kermeta>New Kermeta Project 
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Translate this Kermeta file into an Ecore file 
It is preferable to use an Ecore for our specific needs 
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Create from an Ecore file 
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Generate the editor for the 
model 

•  Right click on families.ecore in Project 
Explorer>New>EMF Generator Model 
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Give the name of your Ecore 
and click on load to see the Next button 
enabled  
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Right-click on the package 
and click  on Generate all 

The generator model is equivalent to the  
Ecore file but is prepared to build an editor 
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After generation, you can find some new projects 
in your workspace. A plugin (editor + wizard) is  
created for your metamodel 
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Run a new Eclipse from the one you are, and File>New>Project 
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On the project, right click New>Other 
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Create the target metamodel 
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Create the Ecore model persons 
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Create the metamodel as follows 

Generate the generator model 
from this metamodel 

Then generate all 
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Create the transformation rules 

•  File>New>Other>ATL>ATL Project 

Be sure to use an ATL 
project if you don’t want 
to lose time finding the asm file 
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Families2Persons.atl 

-- @path Families=/Families2Persons/Families.ecore 
-- @path Persons=/Families2Persons/Persons.ecore 
 
module Families2Persons; 
create OUT : Persons from IN : Families; 
 
helper context Families!Member def: familyName : String = 

 if not self.familyFather.oclIsUndefined() then 
  self.familyFather.lastName 
 else 
  if not self.familyMother.oclIsUndefined() then 
   self.familyMother.lastName 
  else 
   if not self.familySon.oclIsUndefined() then 
    self.familySon.lastName 
   else 
    self.familyDaughter.lastName 
   endif 
  endif 
 endif; 
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Families2Persons.atl 

helper context Families!Member def: isFemale() : Boolean = 
 if not self.familyMother.oclIsUndefined() then 
  true 
 else 
  if not self.familyDaughter.oclIsUndefined() then 
   true 
  else 
   false 
  endif 
 endif; 
  

rule Member2Male { 
 from 
  s : Families!Member (not s.isFemale()) 
 to 
  t : Persons!Male ( 
   fullName <- s.firstName + ' ' + s.familyName   
  ) 

} 
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Families2Persons.atl 

rule Member2Female { 
 from 
  s : Families!Member (s.isFemale()) 
 to 
  t : Persons!Female ( 
   fullName <- s.firstName + ' ' + s.familyName   
  ) 

} 
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Last step! 

Families2Persons.asm is the assembler version 
of the ATL file for use on the ATL virtual machine 
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Right-click on the ATL file 
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If you are lucky, you should see this 

Another bug: errors are not in Error log tab 
but in Console tab... 
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Kermeta 

Advantages 
•  MDE tool with 

metamodeling, modeling 
and transformation 

 

Drawbacks 
•  Not easy to understand 

the Kermeta notation and 
OCL 

•  Developing from 
metamodels to code is 
long and painful task 
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Labs on Kermeta (MDE) 

•  Install Kermeta 
•  Realize all the steps for a domain (Books-

> Publications, your domain) 
– Source metamodel 
– Source model 
– Target metamodel 
– Transformation rules 
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Domain-specific Languages 
(DSL) 
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Domain-specific Languages 
(DSL) 

 
A domain-specific language (DSL) is a 

programming or executable specification 
language that offers, through appropriate 
notations and abstractions, expressive 
power focused on, and usually restricted 
to, a particular problem domain. 
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Domain-specific Languages 
(cont’d) 

•  MDA and MDE provide editors to create 
metamodels and models, ideal for users 
not fluent with computers 

•  Developers prefer some programming 
approaches 

•  Ease reuse by copy and paste 
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Domain-specific Languages 
(cont’d) 

•  You already know some DSL... 
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Domain-specific Languages 
(cont’d) 

•  Microsoft Excel macro commands 
•  Visual Basic for Applications 
•  *nix commands 
•  Matlab 
•  SQL 



Page 174 

Domain-specific Languages  
(cont’d) 

Several alternatives to realize DSLs: 
•  The old (geek?) school: use a lexer (lex, 

flex) and a parser (yacc, bison) to create a 
DSL, use Emacs to use the DSL 

•  The fashion way: use a dynamic language 
(Smalltalk, Ruby) 

•  The model-driven way: use Xtext 
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DSL in practice 
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Xtext 

•  Framework for the development of 
domain-specific languages 

•  Fully benefits of Eclipse 
– Syntax coloring 
– Code completion 
– Code templates 
– Eclipse perspectives and views 

•  Model to Text tool 
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Create a project 
File>New>Xtext>Xtext Project 
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CV 
CV 
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Your grammar 

Code generator 

Editor, Code completion 
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The grammar for your DSL, looks like a model... 
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Book DSL 

•  Libraries 
–  Contains Books 

•  Books 
–  Title 
–  One or more Authors 
–  One or more Chapters 

•  Authors 
–  First Name, Last Name, Date of Birth 

•  Chapters 
–  Number 
–  Number of Pages 
–  Text 
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Here is our grammar in Xtext 
Terminals between quote characters 
Nonterminals with a ‘;’ 
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Run this file to create the language generator 

Then selects the project, and  
execute it 
 as an Eclipse application 
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In this second Eclipse, create a new project File>New>General>Project 
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Be sure to suffix your file with 
the extension you used in the project 



Page 186 

Code completion 

Syntax coloring 
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The current grammar was limited, it is difficult to enter data,  
Update the grammar as follows 
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One final step 

•  Xtext approach: 
– Code generating from the model defined 

before. 
•  Still incomplete in Xtext 
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Labs in Xtext (DSL) 

•  Install Xtext 
•  Develop a DSL for publications (like Bibtex 

but simplify the metamodel) 
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Conclusion 

•  Model-driven Architecture is a reality in 
industry 

•  Developers have to be trained to work on 
Model-driven Engineering 

•  Several tools available: 
– MDA 
– MDE 
– M2M 
– M2T 
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Thanks a lot for your attention 
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